Build 20170604030657: failure

Build Properties

NameValue
binary_version0.10.5pre1-ge5ed66-i386-build20170604030657
build_number20170604030657
builderi386
dist_commit1c0b0dca0a7b85e99c35f9e20ea94dee1bd147b3
dist_dirpspp-0.10.5pre1-ge5ed66
dist_refrefs/builds/20170604030657/dist
dist_version0.10.5pre1-ge5ed66

Build Products

Build Summary

  1. Starting from /home/blp/tmp/pspptmp/master/source/results/pspp-0.10.5pre1-ge5ed66.tar.gz (log)
  2. Save tarball to Git (log)
  3. Determining /home/blp/tmp/pspptmp/master/source/results/pspp-0.10.5pre1-ge5ed66.tar.gz target directory (log)
  4. Extracting source tarball (log)
  5. Extracting tar version (log)
  6. Configuring (log)

    config.h (log)

    config.log (log)

  7. Build (log)

    ../lib/gtk-contrib/gtkxpaned.c:1479:35: warning: ‘gdk_device_manager_get_client_pointer’ is deprecated [-Wdeprecated-declarations] (log)

    ../lib/gtk-contrib/gtkxpaned.c:1480:37: warning: ‘gdk_display_get_device_manager’ is deprecated: Use 'gdk_display_get_default_seat' instead [-Wdeprecated-declarations] (log)

    ../lib/gtk-contrib/gtkxpaned.c:1684:3: warning: ‘gdk_device_grab’ is deprecated: Use 'gdk_seat_grab' instead [-Wdeprecated-declarations] (log)

    ../lib/gtk-contrib/gtkxpaned.c:1787:7: warning: ‘gdk_device_ungrab’ is deprecated: Use 'gdk_seat_ungrab' instead [-Wdeprecated-declarations] (log)

    ../lib/gtk-contrib/gtkxpaned.c:1795:7: warning: ‘gdk_device_ungrab’ is deprecated: Use 'gdk_seat_ungrab' instead [-Wdeprecated-declarations] (log)

    ../lib/gtk-contrib/gtkxpaned.c:1804:7: warning: ‘gdk_device_ungrab’ is deprecated: Use 'gdk_seat_ungrab' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-data-sheet.c:658:3: warning: ‘gtk_menu_popup’ is deprecated: Use '(gtk_menu_popup_at_widget, gtk_menu_popup_at_pointer, gtk_menu_popup_at_rect)' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-data-sheet.c:1364:3: warning: ‘gtk_menu_popup’ is deprecated: Use '(gtk_menu_popup_at_widget, gtk_menu_popup_at_pointer, gtk_menu_popup_at_rect)' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-dictview.c:520:3: warning: ‘gtk_menu_popup’ is deprecated: Use '(gtk_menu_popup_at_widget, gtk_menu_popup_at_pointer, gtk_menu_popup_at_rect)' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-output-view.c:118:3: warning: ‘gdk_cairo_create’ is deprecated: Use 'gdk_window_begin_draw_frame() and gdk_drawing_context_get_cairo_context()' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-output-view.c:185:7: warning: ‘gtk_widget_override_background_color’ is deprecated [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-output-view.c:188:7: warning: ‘gtk_widget_override_background_color’ is deprecated [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-output-view.c:215:3: warning: ‘gdk_cairo_create’ is deprecated: Use 'gdk_window_begin_draw_frame() and gdk_drawing_context_get_cairo_context()' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-output-view.c:320:7: warning: ‘gdk_cairo_create’ is deprecated: Use 'gdk_window_begin_draw_frame() and gdk_drawing_context_get_cairo_context()' instead [-Wdeprecated-declarations] (log)

    ../src/ui/gui/psppire-var-sheet.c:955:3: warning: ‘gtk_menu_popup’ is deprecated: Use '(gtk_menu_popup_at_widget, gtk_menu_popup_at_pointer, gtk_menu_popup_at_rect)' instead [-Wdeprecated-declarations] (log)

    Warning: the following files are missing in your kit: (log)

    /home/blp/tmp/pspptmp/master/i386/pspp-0.10.5pre1-ge5ed66/_build/config.h:2434:0: warning: "VERSION" redefined (log)

  8. Install (log)

    libtool: install: warning: `src/libpspp.la' has not been installed in `/lib/pspp' (log)

    libtool: install: warning: `src/libpspp-core.la' has not been installed in `/lib/pspp' (log)

    libtool: install: warning: `src/libpspp.la' has not been installed in `/lib/pspp' (log)

    libtool: install: warning: `src/libpspp-core.la' has not been installed in `/lib/pspp' (log)

    libtool: install: warning: `src/libpspp-core.la' has not been installed in `/lib/pspp' (log)

    libtool: install: warning: remember to run `libtool --finish /lib/pspp' (log)

  9. Make binary distribution (log)

    pspp-0.10.5pre1-ge5ed66-i386-build20170604030657.tar.gz (log)

  10. Check (log)

    ERROR: 1186 tests were run, (log)

    testsuite.log (log)

    testsuite.dir (log)